设为首页收藏本站

天牛网

 找回密码
 立即注册

QQ登录

只需一步,快速开始

DDE专区 - 证券软件 - 公式指标 - 股票池区 谈股论经 - 实战交流 - 工具软件 - 应用软件

会员风采 - 美图欣赏 - 美食广场 - 开心一笑 心情驿站 - 求职招聘 - 天牛鹊桥 - 驴友天地

网友原创 - 网友互助 - 天牛下载 - 论坛公告 名家视点 - 行业研究 - 财经要闻 - 机构视点

查看: 2823|回复: 1

[大智慧] 六指金叉也就是六个指标金叉源码挺好的 [复制链接]

Rank: 1

威望
0
金币
30
贡献
11
性别
保密
在线时间
11 小时
最后登录
2012-5-25
分享
0
精华
0
积分
41
主题
9
发表于 2012-5-21 08:49:19 |显示全部楼层
{六指金叉}
input:N1(3,1,100),N2(5,1,100),N3(9,1,100),N4(13,1,100);
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,12),ALIGN1;
DRAWICON(DIFF<DEA,1,13),ALIGN1;
DRAWTEXT(BARSTATUS=2,1,' MACD'),COLORFFFFFF;
A1:=DIFF>REF(DIFF,1);
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>REF(K,1),2,12),ALIGN1;
DRAWICON(K<REF(K,1),2,13),ALIGN1;
DRAWTEXT(BARSTATUS=2,2,' KDJ'),COLORFFFFFF;

A2:=K>REF(K,1);
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,3,12),ALIGN1;
DRAWICON(RSI1<RSI2,3,13),ALIGN1;
DRAWTEXT(BARSTATUS=2,3,' RSI'),COLORFFFFFF;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>REF(LWR1,1),4,12),ALIGN1;
DRAWICON(LWR1<REF(LWR1,1),4,13),ALIGN1;
DRAWTEXT(BARSTATUS=2,4,' LWR'),COLORFFFFFF;
A4:=LWR1>REF(LWR1,1);
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,5,12),ALIGN1;
DRAWICON(CLOSE<BBI,5,13),ALIGN1;
DRAWTEXT(BARSTATUS=2,5,' BBI'),COLORFFFFFF;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,6,12),ALIGN1;
DRAWICON(MMS<MMM,6,13),ALIGN1;
DRAWTEXT(BARSTATUS=2,6,' ZLMM'),COLORFFFFFF;

MACD金叉IFF>DEA,COLOR0000FF;
;
KDJ金叉:K>D,COLORFF00FF;
;
RSI金叉:RSI1>RSI2,COLORFFFFFF;
;
LWR金叉WR1>LWR2,COLOR0000FF;
;
BBI金叉:CLOSE>BBI,COLOR00FFFF;
;
MMS金叉:MMS>MMM,COLOR00FF00;
;
MACD金叉 AND KDJ金叉 AND RSI金叉 AND LWR金叉 AND BBI金叉 AND MMS金叉,COLORRED,LINETHICK2;
六指全红AST(MACD金叉 AND KDJ金叉 AND RSI金叉 AND LWR金叉 AND BBI金叉 AND MMS金叉),COLORRED,LINETHICK0;
头像被屏蔽

禁止发言

威望
0
金币
-11
贡献
1
性别
保密
在线时间
1 小时
最后登录
2012-8-7
分享
0
精华
0
积分
-10
主题
0
发表于 2012-8-6 08:37:38 |显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

手机版|天牛网 ( 粤ICP备11104627号 )

GMT+8, 2018-12-15 01:02

Powered by Discuz! X3.2

© 2001-2012 天牛网

回顶部